Browser Compatibility

If you are having an issue seeing a form or our website, you may be using a browser version we do not support.

The ideal Anedot experience is with the latest version of Chrome, Brave or Safari.

Some older browser versions may not support the minimum security requirements in order to be PCI compliant.

Your browser must support TLS v1.2 or v1.3 to make a secure connection to our servers.

We aim to support the latest 2 to 3 releases of major browsers on iOS, iPadOS, Linux, macOS, and Windows. Our list of currently supported platforms include but are not limited to:

  • Android 10, 11, 12, 13 (or newer)

  • Samsung Browser 14, 15, 16 (or newer)

  • Apple Safari 13.1 on Mac OS X 10.13 (High Sierra), iOS 13, iPadOS 13

  • Apple Safari 14 on Mac OS X 10.14 (Mojave), iOS 14, iPadOS 14

  • Apple Safari 15 on macOS 12, macOS 11, Mac OS X 10.15 (Catalina), iOS 15, iPadOS 15

  • Brave 98 (or newer) on Linux, macOS, Windows 10/11

  • Firefox 91 ESR or the latest Extended Support Release on Linux, macOS, Windows 10/11

  • Firefox 98 (or newer) on Linux, macOS, Windows 10/11

  • Google Chrome 98 (or newer) on Linux, macOS, Windows 10/11

  • Microsoft Edge 98 (or newer) on Linux, macOS, Windows 10/11

If you have any questions, please give us an email at help@anedot.com