If you are having an issue seeing a form or our website, it may be that you are using a version of a browser that we do not support.

Some older versions may not support the minimum security requirements in order to be PCI compliant.

Your browser must support TLS v1.2 to make a secure connection to our servers.

Our list of currently supported platforms include but are not limited to:

Android 4.4.2

Android 5.0.0

Chrome 48 / OS X / Win 7/10

Firefox 31.3.0 ESR / Win 7

Firefox 44 / OS X

IE 11 / Win 7, Win 8.1, Win Phone 8.1, Win Phone 8.1 Update, Win 10

Edge 13 / Win 10, Win Phone 10

Safari 6 / iOS 6.0.1

Safari 7 / iOS 7.1, OS X 10.9

Safari 8 / iOS 8.4, OS X 10.10

Safari 9 / iOS 9, OS X 10.11

Apple ATS 9 / iOS 9

If you have any questions, please give our office a call: (225) 250-1301.

Did this answer your question?